テクノロジ関連分野の用語

サーバ証明書とは

サーバ証明書とは、Webサーバなどの身元と公開鍵の対応を、認証局が保証して発行するデジタル証明書である。

HTTPS通信では、ブラウザがサーバから受け取った証明書の署名を認証局の公開鍵で検証し、接続先が正規のサーバであることを確かめる。そのうえで、証明書の公開鍵でサーバの署名を検証して相手を確かめながら、通信を暗号化する鍵を安全に共有する(古い方式では証明書の公開鍵で鍵の元になる値を暗号化して送る)。

試験ではここが問われる

分野: テクノロジ関連分野

出典: RFC 8446 TLS 1.3(1.2節・2節)・RFC 5280 Internet X.509 PKI Certificate and CRL Profile(3.1節)・RFC 5246 TLS 1.2(7.4.7.1節 RSA-Encrypted Premaster Secret Message)

関連する用語

この用語が出てくる問題

情報セキュマネ 用語集の一覧へ